OpenWrt修改IP地址两种方法(直接命令修改跟后台修改)

小路
小路
小路
632
文章
36
评论
2022-04-2816:17:33
评论
1132字阅读3分46秒

OpenWrt是什么?OpenWrt一般常见于无线路由器(软路由)第三方固件,它是一个高效、可靠、功能多的路由器固件。OpenWrt 可以被描述为一个嵌入式的 Linux 发行版。(主流路由器固件有 dd-wrt,tomato,openwrt,padavan四类)对比一个单一的、静态的系统,OpenWrt的包管理提供了一个完全可写的文件系统,从应用程序供应商提供的选择和配置,并允许您自定义的设备,以适应任何应用程序。

OpenWrt修改IP地址两种方法(直接命令修改跟后台修改)

OpenWrt

OpenWrt的网络配置文件是/etc/config/network,它负责交换芯片VLAN、网络接口和路由的配置。

方法一:使用命令修改

我们可以在控制台中输入ifconfig命令来查看系统的IP地址

[email protected]:/# ifconfig

首先在SSH控制台中输入

vi    etc/config/network
[email protected]:~# vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0'
        option _orig_bridge 'true'
        option ifname 'eth0 eth1 eth2'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth3'

只需要将192.168.1.1修改成你想要的IP地址,比如192.168.8.1 按i 进入修改,修改完成按 esc 退出编辑,接着:wq 保存退出,然后保存退出,然后再重启开发板(如果使用命令可以使用reboot),就发现 IP 地址被改为 192.168.8.1 了。

 

方法二:使用WEB控制台修改

登录OpenWrt系统的WEB控制台

点击网络 --> 接口 --> LAN

OpenWrt修改IP地址两种方法(直接命令修改跟后台修改)点击修改,进入LAN接口修改页面

OpenWrt修改IP地址两种方法(直接命令修改跟后台修改)

IPv4 地址中的192.168.1.1修改为自己想要的IP即可,修改完成后,最后点击下方的保存&应用即可。

阅读全文
小米路由器3 Pro(R3P)刷机 OpenWrt 路由器刷机

小米路由器3 Pro(R3P)刷机 OpenWrt

小米路由器Pro能刷OpenWrt固件,小米路由R3G固件OpenWrt固件有很多小米原生没有的功能,比如:bt下载、百度云、aria、usb、rclone、网易云、网络共享、ftp、低调上网、多拨、...
OpenWrt X86-64纯净版软路由固件镜像下载 软路由

OpenWrt X86-64纯净版软路由固件镜像下载

最新编译OpenWrt X86-64纯净版软路由固件镜像下载 LEDE精简版-多功能版-旁路由固件 OpenWRT是一款非常流行、强大的路由器操作系统(固件),很多高级一些的路由器都支持刷机(刷固件)...
匿名

发表评论

匿名网友 填写信息