LEDE软路由 iPTV 实现任意端口看电视的方法

路由网
路由网
路由网
536
文章
5
评论
2019-08-1216:39:26 1 17,188 2773字阅读9分14秒

1、光猫直接连接电脑,超级管理员进入光猫后台

修改光猫为桥接模式,把IPTV 的VLAN ID绑定到跟宽带一样的数据端口。

如下图:

LEDE软路由 iPTV 实现任意端口看电视的方法

LEDE软路由 iPTV 实现任意端口看电视的方法

 

2、软路由,我们以6网口的来演示。

进入Lede后台 系统 —-进阶设置 配置dnsmasq

LEDE软路由 iPTV 实现任意端口看电视的方法

添加代码:

dhcp-option-force=125,00:00:00:00:1a:02:06:48:47:57:2d:43:54:03:04:5a:58:48:4e:0a:02:20:00:0b:02:00:55:0d:02:00:2e

dhcp-option=15

dhcp-option=28

dhcp-option=60,00:00:01:06:68:75:61:71:69:6E:02:0A:48:47:55:34:32:31:4E:20:76:33:03:0A:48:47:55:34:32:31:4E:20:76:33:04:10:32:30:30:2E:55:59:59:2E:30:2E:41:2E:30:2E:53:48:05:04:00:01:00:50

然后到–配置网络

添加代码:

config interface 'iptv'

option proto 'none'

option multipath 'off'

option type 'bridge'

option igmp_snooping '1'

option ifname 'eth0.85 eth.85 eth1.85 eth2.85 eth3.85 eth4.85 eth5.85'

option auto '1'

添加完成 点击 保存并应用

LEDE软路由 iPTV 实现任意端口看电视的方法

然后会出现短暂的卡死不动,不用管它,关闭窗口

重新打开一个新页面 输入 lede的后台IP,重新进入Lede后台

3、点击 网络 — 防火墙 —点击下面 【添加】

LEDE软路由 iPTV 实现任意端口看电视的方法

共享名:iptv

入站数据:接受

出站数据:接受

转发:接受

网络覆盖:iptv 打勾

设置好之后,点击 保存应用

4、点击 —-网络—接口 IPTV –编辑 —-防火墙设置

LEDE软路由 iPTV 实现任意端口看电视的方法

转件/分配防火墙区域:iptv

设置好之后 保存应用

 

5、最后检查一下 各项设置是否一致,没问题的话就系统–重启

把路由重启一下,配置就生效了。

————————————

【进阶设置】

配置dsnmasq代码:

dhcp-option-force=125,00:00:00:00:1a:02:06:48:47:57:2d:43:54:03:04:5a:58:48:4e:0a:02:20:00:0b:02:00:55:0d:02:00:2e
dhcp-option=15
dhcp-option=28
dhcp-option=60,00:00:01:06:68:75:61:71:69:6E:02:0A:48:47:55:34:32:31:4E:20:76:33:03:0A:48:47:55:34:32:31:4E:20:76:33:04:10:32:30:30:2E:55:59:59:2E:30:2E:41:2E:30:2E:53:48:05:04:00:01:00:50

配置网络代码:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd52:893e:5328::/48'
option multipath 'disable'
option mptcp_path_manager 'fullmesh'
option mptcp_scheduler 'default'
option mptcp_checksum '0'
option mptcp_debug '0'
option mptcp_syn_retries '5'
option mptcp_fullmesh_num_subflows '1'
option mptcp_fullmesh_create_on_err '1'
option mptcp_ndiffports_num_subflows '1'
option congestion 'olia'


config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth1 eth2 eth3 eth4'
option proto 'static'
option ipaddr '192.168.100.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.100.1'
option multipath 'off'
option dns '114.114.114.114 223.5.5.5'

config interface 'wan'
option ifname 'eth5'
option proto 'dhcp'
option metric '40'

config interface 'iptv'
option proto 'none'
option multipath 'off'
option type 'bridge'
option igmp_snooping '1'
option ifname 'eth0.85 eth1.85 eth2.85 eth3.85 eth4.85 eth5.85'
option auto '1'

注意!上面的:

[option ifname ‘eth0 eth1 eth2 eth3 eth4’]

[option ipaddr ‘192.168.100.1’],[option gateway ‘192.168.100.1’]

[option ifname ‘eth5’],[option proto ‘dhcp’],

[option ifname ‘eth0.85 eth1.85 eth2.85 eth3.85 eth4.85 eth5.85’]

可根据自己的设备实际情况来更改IP地址和端口数量

LEDE软路由 iPTV 实现任意端口看电视的方法

注意:

由于我这里演示原因,之前把IPV6删除了, 麻烦就不添加了。

实际情况下 IPV6的WAN6 不要删除,并且网卡绑定要跟WAN一致。

LEDE软路由 iPTV 实现任意端口看电视的方法

基本设置:协议:不配置协议

LEDE软路由 iPTV 实现任意端口看电视的方法

高级设置:开机启动运行 打勾,使用内置的IPV6管理 打勾

LEDE软路由 iPTV 实现任意端口看电视的方法

桥接接口:打勾

启用IGMP嗅探:打勾 (这个非常重要 这是组播功能

LEDE软路由 iPTV 实现任意端口看电视的方法

防火墙设置:选择之前创建好的 iptv 专用防火墙

LEDE软路由 iPTV 实现任意端口看电视的方法

防火墙:这个是新添加好的防火墙界面

LEDE软路由 iPTV 实现任意端口看电视的方法

iptv专用防火墙的基本设置:

转发:接受

覆盖网络:iptv 端口组

—————————

没问题 就 重启系统

然后 1~5口 都可以接 IPTV 的机顶盒

建议在进阶设置里面,把配置dnsmasq、网络、防火墙

3个页面的代码 复制到 记事本上。

以后可以直接粘贴导入,恢复配置。

 

注意部分:

dnsmasq里面的 代码 跟 IPTV机顶盒息息相关的

DHCP Option 端口代码 不同地区的IPTV机顶盒

代码不一样,这里需要wireshark抓包分析

LEDE软路由 iPTV 实现任意端口看电视的方法

从听说到上手 软路由入门指南 软路由

从听说到上手 软路由入门指南

软路由估计一些小伙伴们都听说过,但是却不懂软路由是一个什么东西,软路由怎么选、安装哪个系统好?它到底有多强? 究竟什么是软路由? 就像计算机有软件和硬件的区别,路由器也有「软」「硬」之分。通常我们常见...
电信的IPTV网络盒子怎么连接? 路由器百科

电信的IPTV网络盒子怎么连接?

IPTV盒子,本就是跟宽带在同一条光纤内传输,不管你加不加路由器,还是交换机。IPTV是不占用网速的,它有专门的通道。 你脑海中瞬间浮现好几种连接方式,那种是最优选择?   运营商赠送的IP...
路由器之:AC+AP及软路由 软路由

路由器之:AC+AP及软路由

AC+AP选购要点及避坑指南 AC+AP的模式最早应用于企业、商业级别场景,稳定性和用户体验一直都是AC+AP方案首要目标。随着家用覆盖面积的变大,AC+AP成为高端家庭用户的选择。 就网络体验而言A...
什么是软路由和硬路由,两者的区别有什么? 软路由

什么是软路由和硬路由,两者的区别有什么?

路由器我们每天都会在用,但是很多伙伴并不了解路由器其实分为软路由和硬路由。那么软路由和硬路由两者有什么区别呢? 软路由器其实是在电脑主机的基础上配合软件组合成的路由解决方案,路由的参数通过软件控制和设...
匿名

发表评论

匿名网友 填写信息

评论:1   其中:访客  1   博主  0
    • dylan dylan 0

      楼主您好!
      有没有测试过 ESXI 实现爱快+LEDE 在LEDE上面设置组播的情况呢?不知道这种是否可行?
      爱快拨号上网 LEDE旁路 然后启用一个 IPTV拨号 设置组播 下面的LAN 在访问组播的时候走 LEDE的IPTV拨号端口,其他的默认走爱快